summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorChris Hiszpanski <chris@hiszpanski.name>2019-04-18 00:55:30 -0700
committerChris Hiszpanski <chris@hiszpanski.name>2021-04-04 01:23:16 -0700
commit6d88c555019f32509f303e23dcfbba824fecd2ee (patch)
tree9d976063b4cb63e2e8ad4529c6d597b4470464c7 /tests/Makefile.am
Initial public commit.
mDNS and SDP are functional. Otherwise, library is still very much a work in progress. All tests pass.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..27ebf83
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,32 @@
+# Build test programs (run with 'make check')
+TESTS = $(check_PROGRAMS)
+check_PROGRAMS = \
+ g711_test \
+ mdns_test \
+ sdp_test \
+ uuid_test
+
+g711_test_CFLAGS = -I$(top_srcdir)/src
+g711_test_SOURCES = \
+ g711_test.c \
+ $(top_srcdir)/src/g711.c \
+ $(top_srcdir)/src/g711_tables.c
+g711_test_LDADD = $(top_builddir)/src/liburtc.la
+
+mdns_test_CFLAGS = -I$(top_srcdir)/src
+mdns_test_SOURCES = \
+ mdns_test.c \
+ $(top_srcdir)/src/mdns.c
+mdns_test_LDADD = $(top_builddir)/src/liburtc.la
+
+sdp_test_CFLAGS = -I$(top_srcdir)/src
+sdp_test_SOURCES = \
+ sdp_test.c \
+ $(top_srcdir)/src/sdp.c
+sdp_test_LDADD = $(top_builddir)/src/liburtc.la
+
+uuid_test_CFLAGS = -I$(top_srcdir)/src
+uuid_test_SOURCES = \
+ uuid_test.c \
+ $(top_srcdir)/src/uuid.c
+uuid_test_LDADD = $(top_builddir)/src/liburtc.la