summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Hiszpanski <chris@hiszpanski.name>2019-04-18 00:55:30 -0700
committerChris Hiszpanski <chris@hiszpanski.name>2021-04-04 01:23:16 -0700
commit6d88c555019f32509f303e23dcfbba824fecd2ee (patch)
tree9d976063b4cb63e2e8ad4529c6d597b4470464c7 /configure.ac
Initial public commit.
mDNS and SDP are functional. Otherwise, library is still very much a work in progress. All tests pass.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c6a74a3
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,23 @@
+AC_INIT([liburtc], [1.0.0], [chris@hiszpanski.name])
+
+# custom m4 macros within m4/ subdirectory
+AC_CONFIG_MACRO_DIR([m4])
+
+AM_INIT_AUTOMAKE([-Wall -Werror foreign no-dependencies subdir-objects])
+AC_PROG_CC
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_LIBOBJ_DIR([src])
+
+# for pthread support on linux
+AX_PTHREAD(,[AC_MSG_ERROR([Could not configure pthreads support])])
+
+AM_PROG_AR
+LT_INIT
+
+AC_CONFIG_FILES([
+ Makefile
+ examples/Makefile
+ src/Makefile
+ tests/Makefile
+])
+AC_OUTPUT